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Abstract

Sperm head morphology has been identified as a characteristic that can be used to predict a male’s semen quality. In the present
study, we have developed an automated sperm head morphology analysis (ASMA) plug-in for open-source ImageJ software
(http://rsbweb.nih.gov/ij/). We describe the plug-in’s functionality, and confirm its validity for sperm head morphology analysis
using fish sperm. Sperm head morphological measurements (length and width) made with the ASMA plug-in did not differ from
manual measurements. Using the plug-in to measure sperm head-shaped objects of known size, the associated plug-in error rate
was ! 0.5%. Brightness and contrast ratios influenced sperm head measurements, suggesting the need for standardized protocols.
This plug-in was effective at measuring elliptical (i.e., Atlantic cod) as well as slightly irregular (i.e., Chinook salmon) shaped
sperm heads. In conclusion, our ASMA plug-in represents a versatile alternative to costly sperm morphology software.
© 2011 Elsevier Inc. All rights reserved.
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1. Introduction

Sperm morphology has been identified as a charac-
teristic that can be used to predict a male’s ability to
fertilize an egg in competitive and non-competitive
contexts [1,2]. Morphological assessment of sperm also
has importance in the investigation of biotechnology to
cryopreserve sperm [3–5], assessing triploidy [6], male

infertility [7], the impact of pollutants on sperm quality
[8], describing the effects of water and saline solutions
on sperm functionality [9], evolutionary significance of
sperm form and function [10], and phylogenetic clas-
sification [11].

Several microscopic techniques have been used to
study sperm morphology. For instance, scanning elec-
tron microscopy, transmission electron microscopy and
cryo-electron microscopy have been widely used to
examine morphology and ultrastructure of sperm [12–14].
Although these systems provide greater resolving
power than a traditional light-powered optical micro-
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scope, there are some disadvantages. For example:
electron microscopes are costly; specialized equipment
and numerous chemicals are required to prepare sam-
ples; selection of an appropriate fixative and method-
ology for sample preparation needs to be considered;
interactions between artificial media and fixatives need
to be known; and preparation of slides, image capture
and data analysis are time consuming, especially to
obtain the large samples sizes required for high statis-
tical power. Therefore, more conventional microscopic
techniques, such as dark-field microscopy in combina-
tion with stroboscopic light, and phase contrast micro-
scopes, have been used to study sperm morphology
[15]. More recently, automated sperm morphology
analysis (ASMA) software has been developed to pro-
cess morphology samples [16,17]. This computer-
driven software has advantages over other types of
microscopy, as it provides faster, automated assessment
of sperm morphology [18]. However, these ASMA
systems can be expensive, as well as require standard-
ized staining techniques.

In the present study, we explored the use of open-
source ImageJ software as an alternative to expensive
systems for automatically measuring sperm head mor-
phology. An open-source computer assisted sperm
analysis (CASA) plug-in has already been developed
for ImageJ to quantify sperm movement, and our
plug-in will compliment this software [19]. Thus, the

objectives of the present study were to present a freely
available ASMA plug-in, describe its functionality, and
confirm its validity for sperm head morphology analy-
sis using Atlantic cod (Gadus morhua). Atlantic cod
sperm samples were used to: (i) compare sperm head
length and width from the ASMA plug-in and manual
measurements; (ii) determine the accuracy and preci-
sion of the ASMA plug-in using calibrated sperm head
shapes; and (iii) establish the ASMA plug-in’s image
detection thresholds using various brightness and con-
trast ratios. In addition to the above objectives, the
versatility of the ASMA plug-in for measuring less
elliptical sperm head shapes was tested using Chinook
salmon (Oncorhynchus tshawytscha) sperm.

2. Materials and methods

Detailed methodology for sperm collection, staining,
digital imagery and functional operation of the ASMA
plug-in are provided via the Supplementary material
(available in the online version only).

In the present study, for each Atlantic cod male (n "
15), 30 sperm were captured and measured using the
ASMA plug-in (Fig. 1). The same 30 sperm, per male,
were manually measured in ImageJ [20].

To determine the accuracy and precision of the
ASMA plug-in, 50 calibrated sperm head shapes were

Fig. 1. Digital image of Atlantic cod Gadus morhua sperm before (A) and after (B) running the automated sperm morphology analysis (ASMA)
plug-in. The sperm image was captured at the 50:50 brightness to contrast ratio.
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created using CorelDRAW. These artificial sperm
heads were elliptical in shape and had lengths ranging
from 1.3 to 3.5 !m and widths ranging from 1.0 to 2.0
!m. The ratio of sperm head length:width ranged from
1.2 to 3.0. The ASMA plug-in was then used to mea-
sure length and width of these calibrated shapes and
associated error rates [ER " (plug-in value – actual
value/actual value) # 100] were generated.

Furthermore, to establish the ASMA plug-ins image
detection thresholds, 50 Atlantic cod sperm were cap-
tured, using a factorial design, over a series of six
brightness (20, 40, 50, 60, 80 and 100) and six contrast
values (20, 40, 50, 60, 80 and 100). The 50:50 bright-
ness to contrast ratio then served as the control and
associated ER deviating from these values were gener-
ated for the other brightness to contrast ratios.

To test the versatility of the ASMA plug-in a total of
50 Chinook salmon sperm, from a pooled semen sam-
ple (n " 5 males), were captured at the 50:50 bright-
ness to contrast ratio and then measured using the
ASMA plug-in. The same 50 sperm were manually
measured in ImageJ.

2.1. Statistical analyses

All data were analyzed using SAS statistical analysis
software [version 9.1; 21]. Residuals were tested for
normality (Shapiro-Wilk test; PROC UNIVARIATE)
and homogeneity of variance (plot of residuals vs pre-
dicted values; PROC GPLOT). As needed, data were
log10 transformed to meet assumptions of normality
and homoscedasticity. Alpha was set at 0.05. To com-
pare Atlantic cod sperm head length and width from the
ASMA plug-in and manual measurements, repeated
measures mixed-model ANOVAs were run (PROC
MIXED) using the following model:

Yipn " ! # Mi # Tp # MTip # $n(ip)

where ! is the population mean; Mi is the male effect
(where i " male 1 to 15); Tp is the effect of treatment
(where p " ASMA plug-in and manual measurement);
MTip is the male # treatment interaction; and $n(ip) is
the residual error. Treatment was considered fixed,
whereas male and the corresponding male # treatment
interaction were considered random (PROC MIXED).
The Satterthwaite procedure was used to approximate
the denominator degrees of freedom for F-tests [22].
The repeated statement (Repeated treatment/Subject "
sperm) was used to model the covariance structure
within subjects [23]. Treatment means were contrasted
using the least squares means method [LSMEANS/CL
adjust " TUKEY, PROC MIXED]. Linear regressions

were used to determine the relationship between the
ASMA plug-in and manual measurement (PROC
REG). Relationships were generated for both Atlantic
cod sperm head length and width. For Chinook salmon
a paired Student’s t-test (PROC TTEST) was used to
compare treatment means (ASMA plug-in versus man-
ual measurement). Data are presented as mean $ SEM.

3. Results

Atlantic cod sperm head length did not differ (F1,14 "
0.80, P % 0.05) when measurements were obtained
from the ASMA plug-in or manually measured (3.147 $
0.050 and 3.150 $ 0.050 !m, respectively). In addition,
Atlantic cod sperm head width did not differ (F1,14 "
4.04, P % 0.05) between the ASMA plug-in and manual
measurement (1.905 $ 0.040 and 1.897 $ 0.040 !m,
respectively). Regression analyses demonstrated highly
significant relationships between the ASMA plug-in
and manual measurements for Atlantic cod sperm head
length (R2 " 0.96, P ! 0.0001, y " 1.0067x – 0.0181)
and width (R2 " 0.95, P ! 0.0001, y " 1.0198x –
0.0424). The slopes for these relationships were not
significantly different than 1.0 for both length (df "
455, t " 0.74, P % 0.05) and width regressions (df "
452, t " 1.83; p % 0.05).

Length and width of the 50 calibrated shapes were
2.712 $ 0.065 and 1.481 $ 0.034 !m, respectively.
When measuring these same shapes using the ASMA
plug-in, mean length was 2.715 $ 0.065 !m and width
was 1.485 $ 0.034 !m for associated plug-in ER of
0.13 and 0.34%. Re-running the ASMA plug-in gener-
ated the same results for successive analyses of the
same data (data not shown).

Atlantic cod sperm heads were detected and mea-
sured by the ASMA plug-in at 21 of the 36 brightness
to contrast ratios tested (Table 1). To explore how
brightness and contrast ratios impacted Atlantic cod
sperm size assessment, the 50:50 brightness to contrast
ratio was used as the control (Table 1). The ER devi-
ating from the control ranged from &0.03 to &6.7% for
length and 0.0 to 8.5% for width (Table 1). For both
these indices, the 40:50 brightness to contrast ratio had
the lowest ER (Table 1). In general, ER increased at the
80 and 100 brightness ratios (Table 1).

Chinook salmon sperm head length did not differ
(t " 1.34, df " 49, P % 0.05) when measurements were
obtained from the ASMA plug-in (2.851 $ 0.011 !m)
or manually measured (2.849 $ 0.011 !m). In addition,
salmon sperm head width did not differ (t " 1.81, df "
49, P % 0.05) between the plug-in and manual mea-
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surement (2.292 $ 0.017 and 2.288 $ 0.017 !m,
respectively).

4. Discussion

Sperm morphology is influenced by genetic and en-
vironmental components experienced by an individual
during development [24,25], as well as, by numerous
factors applied to sperm cells during sample prepara-
tion (i.e., staining techniques, and the quality of the
image analysis system). Adding to this complexity is
that sperm morphological assessment is often con-
founded by a researcher’s individual bias and inconsis-
tency, thus making accurate interpretations of findings
between laboratories difficult [16]. Standardized stain-
ing techniques, like those employed for fish [26], bull
[27], boar [28] and humans [29], can increase sample
validity, especially when contrast ratios between the
sperm image and background are “optimized”. In ad-
dition, ASMA programs, such as the Sperm-Class An-
alyzer [17], Sperm Morphometry Module of ISAS [26],
and the Metrix Oval Head Morphology software com-
ponent of the Hamilton-Thorne CEROS system [16]
pose means of generating reproducible and quantitative
measurements of sperm cells.

In the present study, we have developed a freely
available ASMA plug-in for open source software, de-
scribed the systems functionality (via the Supplemen-
tary material), and confirmed its validity. With respect

to the ASMA plug-ins’ data generating capabilities, a
total of nine morphological indices are automatically
measured (e.g., area, perimeter, roundness) [20], and
additional indices such as ellipticity and elongation can
be manually calculated [26]. The majority of these
indices have been proven valuable for predicting male
fertility [2,30], sperm velocity [10], and/or post-thaw
sperm performance [31].

Similar to species such as the ram [17], red deer
[31], bull [32], and brown bear [33], after staining fish
sperm, it is difficult to distinguish the head from the
midpiece, unless specific staining procedures are used
to differentiate the nucleus (DNA) from the mitochon-
dria. Nevertheless, our plug-in was unable to discrim-
inate between colors. Therefore, it should be noted that
measurements obtained from the ASMA plug-in incor-
porated both these morphological structures. Our re-
sults showed no significant differences in length and
width of sperm heads when data were generated from
the plug-in or manually measured. The slope of regres-
sion analysis also demonstrated highly significant rela-
tionships between the ASMA plug-in and manual mea-
surement treatment and were not different from 1.0,
suggesting that there were no systematic biases when
the two measurement approaches were compared.

To examine inter- and intra-male variability in
sperm head morphology indices, data sets containing
'10,000 to 23,000 sperm cells have been easily ob-
tained using our ASMA plug-in [25,34]. In this study,

Table 1
Atlantic cod sperm (n " 50) were captured over a series of six brightness and contrast ratios (20, 40, 50, 60, 80 and 100). The plug-in was
then used to measure length and width of these sperm. The 50:50 brightness to contrast ratio served as the control and associated error rates
deviating from these values were generated for the other ratios. Mean values are reported for each ratio and associated error rates are in
brackets.

Contrast

20 40 50 60 80 100

Length (!m)*
Brightness

20 ND ND ND ND ND ND

40 ND 3.007 (0.7) 2.986 (&0.03) 2.976 (&0.4) ND ND

50 ND 3.039 (1.7) 2.987 (0.0)C 2.967 (&0.7) ND ND

60 ND 3.066 (2.6) 3.011 (0.8) 2.963 (&0.8) ND ND

80 3.162 (5.9) 3.104 (3.9) 3.062 (2.5) 3.004 (0.6) 2.917 (&2.3) 2.788 (&6.7)
100 3.052 (2.2)IT 3.058 (2.4)IT 3.073 (2.9)IT 3.066 (2.6)IT 3.062 (2.5)IT 3.065 (2.6)IT

Width (!m)*
Brightness

20 ND ND ND ND ND ND

40 ND 1.882 (0.7) 1.868 (0.0) 1.863 (&0.3) ND ND

50 ND 1.909 (2.2) 1.868 (0.0)C 1.857 (&0.6) ND ND

60 ND 1.937 (3.7) 1.888 (1.1) 1.849 (&1.0) ND ND

80 2.027 (8.5) 1.972 (5.6) 1.931 (3.4) 1.887 (1.0) 1.804 (&3.4) 1.713 (&8.3)
100 1.929 (3.3)IT 1.935 (3.6)IT 1.933 (3.5)IT 1.937 (3.7)IT 1.938 (3.7)IT 1.864 (&0.2)IT

ND Sperm were not detectable by the plug-in; * SEM was $ 0.02; C Represents the control; IT Sperm were incorrectly traced by the plug-in.
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it took '1.25 h to measure sperm morphology (n " 15
males # 30 sperm) using our ASMA plug-in, whereas
'13 h was needed to manually measure these same
sperm samples. Thus, this is a highly time-efficient
system ('10x faster) for evaluation of sperm head
morphology and avoids bias introduced by different
people conducting morphological measurements. When
testing the ASMA plug-in against calibrated shapes, it
produced accurate (ER ! 0.5%) and precise results. An
important part of the sperm measurement procedure
was standardization of image quality settings. Bright-
ness and contrast ratios influenced sperm measure-
ments. Therefore, when using this plug-in, or any
sperm software, it is important to standardize measure-
ment conditions, especially with respect to brightness
and contrast ratios. This essentially will reduce the
probability of errors associated with an algorithm’s
inability to discern sperm detection boundaries.

In conclusion, our freely available ASMA plug-in,
for open source ImageJ software, represents an alter-
native method to costly ASMA software. The plug-in is
effective at measuring elliptical (i.e., cod) as well as
slightly irregular (i.e., Chinook salmon) sperm heads.
Replication of our system should be possible by other
laboratories, as should modification of the settings to fit
a particular cell size.

Appendix A. Supplementary data

Supplementary data associated with this article
can be found, in the online version, at doi:10.1016/
j.theriogenology.2011.06.019.

Acknowledgments

Funding for this study was provided by the Atlantic
Cod Genomics and Broodstock Development Program,
NSERC, Canadian Foundation for Innovation, Ontario
Ministry of Research and Innovation and an Ontario
Ministry of Research and Innovation Postdoctoral Fel-
lowship. S.M.H.A. was supported by CZ.1.05/2.1.00/
01.0024, GACR 523/09/1793, and GAJU 047/2010/
Z. N. Vischer provided advice on the development of
plug-ins for ImageJ. We would like to thank Dr. J.
Garde for a discussion on sperm morphology.

References

[1] Kleven O, Laskemoen T, Fossøy F, Robertson RJ, Lifjeld JT.
Intraspecific variation in sperm length is negatively related to
sperm competition in passerine birds. Evolution 2008;62:
494–9.

[2] Tsakmakidis IA, Lymberopoulos AG, Khalifa TAA. Relationship
between sperm quality traits and field-fertility of porcine semen. J
Vet Sci 2010;11:151–4.

[3] Butts IAE, Litvak MK, Kaspar V, Trippel EA. Cryopreservation
of Atlantic cod Gadus morhua L. spermatozoa: effects of ex-
tender composition and freezing rate on sperm motility, velocity
and morphology. Cryobiology 2010;61:174–81.

[4] Gwo JC, Arnold CR. Cryopreservation of Atlantic croaker sper-
matozoa – evaluation of morphological changes. J Exp Zool
1992;264:444–53.

[5] Lahnsteiner F, Weismann T, Patzner RA. Fine-structural
changes in spermatozoa of the grayling, Thymallus thymallus
(Pisces, Teleostei), during routine cryopreservation. Aquacul-
ture 1992;103:73–84.

[6] Feindel NJ, Benfey TJ, Trippel EA. Competitive spawning
success and fertility of triploid male Atlantic cod Gadus
morhua. Aquacult Environ Interact 2010;1:47–55.

[7] Obara H, Shibahara H, Tsunoda H, Taneichi A, Fujiwara H,
Takamizawa S, Idei S, Sato I. Prediction of unexpectedly
poor fertilization and pregnancy outcome using the strict
criteria for sperm morphology before and after sperm sepa-
ration in IVF-ET. Int J Androl 2001;24:102– 8.

[8] Hatef A, Alavi SMH, Butts IAE, Policar T, Linhart O. The mech-
anism of action of mercury on sperm morphology, adenosine
triphosphate content, and motility in Perca fluviatilis (Percidae;
Teleostei). Environ Toxicol Chem 2011;30:905–14.

[9] Billard R. Changes in structure and fertilizing ability of
marine and freshwater fish spermatozoa diluted in media of
various salinities. Aquaculture 1978;14:187–98.

[10] Lüpold S, Calhim S, Immler S, Birkhead TR. Sperm morphol-
ogy and sperm velocity in passerine birds. Proc R Soc B 2009;
276:1175–81.

[11] Michalik P, Mercati D. First investigation of the spermatozoa of a
species of the superfamily Scorpionoidea (Opistophthalmus pen-
rithorum, Scorpionidae) with a revision of the evolutionary and
phylogenetic implications of sperm structures in scorpions (Cheli-
cerata, Scorpiones). J Zool Sys Evol Res 2010;48:89–101.

[12] Holt WV, Penfold LM, Johnston SD, Temple-Smith P, McCa-
llum C, Shaw J, Lindemans W, Blyde D. Cryopreservation of
macropodid spermatozoa: new insights from the cryomicro-
scope. Reprod Fert Develop 1999;11:345–53.

[13] Macro-Jiménez F, Pérez L, Viudes de Castro MP, Garzón DL,
Peñaranda DS, Vicente JS, Jover M, Asturiano JF. Morphom-
etry characterisation of European eel spermatozoa with comput-
er-assisted spermatozoa analysis and scanning electron micros-
copy. Theriogenology 2006;65:1302–10.

[14] Lahnsteiner F, Patzner RA. Sperm morphology and ultrastruc-
ture in fish. In: Alavi SMH, Cosson J, Coward K, Rafiee G,
editors. Fish Spermatology. Alpha Science International Ltd.;
Oxford, U.K., 2008, p. 1–61.

[15] Briskie JV, Montgomerie R, Birkhead TR. The evolution of
sperm size in birds. Evolution 1997;51:937–45.

[16] Rijsselaere T, Van Soom A, Hoflack G, Maes D, de Kruif A.
Automated sperm morphometry and morphology analysis of
canine semen by the Hamilton-Thorne analyser. Theriogenol-
ogy 2004;62:1292–306.

[17] Maroto-Morales A, Ramón M, García-Álvarez O, Soler AJ,
Esteso MC, Martínez-Pastor F, Pérez-Guzmán MD, Garde
JJ. Characterization of ram (Ovis aries) sperm head mor-
phometry using the Sperm-Class Analyzer. Theriogenology
2010;73:437– 48.

1760 I.A.E. Butts et al. / Theriogenology 76 (2011) 1756–1761

http://dx.doi.org/10.1016/j.theriogenology.2011.06.019
http://dx.doi.org/10.1016/j.theriogenology.2011.06.019


[18] Cabrita E, Sarasquete C, Martínez-Páramo S, Robles V, Beirão J,
Pérez-Cerezales, Herráez MP. Cryopreservation of fish sperm: ap-
plications and perspectives. J Appl Ichthyol 2010;26:623–35.

[19] Wilson-Leedy JG, Ingermann RL. Development of a novel
CASA system based on open source software for characteriza-
tion of zebrafish sperm motility parameters. Theriogenology
2007;67:661–72.

[20] Ferreira T, Rasband W. The ImageJ User Guide—
Version1.44. Available at: http://imagej.nih.gov/ij/docs/user-
guide.pdf. Accessed February 2011.

[21] SAS Institute Inc. SAS System v. 9.1, SAS Institute Incorpo-
rated, 2003.

[22] Spilke J, Piepho HP, Hu X. Analysis of unbalanced data by
mixed linear models using the Mixed procedure of the SAS
system. J Agron Crop Sci 2005;191:47–54.

[23] Littell RC, Milliken GA, Stroup WW, Wolfinger RD. SAS
System for Mixed Models. SAS Institute Incorporated; 1996.
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S1. Supplementary material

S1.1. Atlantic cod sperm collection and sample
preparation

Wild Atlantic cod were captured from the Bay of
Fundy, Canada in 2004. Fish were fed a mixture of frozen
baitfish. In February and March 2005, gametes were
stripped from these fish and first filial generation (F1)
families were created using IVF. Embryo incubation and
larval rearing followed standard aquaculture protocols [1].
Juveniles were placed into common tanks in September
2005. Each tank was equipped with flow-through seawa-
ter and housed under a natural photoperiod regime. These
fish were fed daily with a marine grower pelletized diet
(EWOS Canada, Surrey, BC, Canada). During the spawn-
ing season fish were maintained between 3 and 5 °C.
Semen samples were collected from 15 of these F1 cod
(weight " 1374.3 $ 592.1 g, length " 46.9 $ 1.2 cm)
during March 2008. Prior to sample collection, fish were
anesthetized with MS-222 (76 mg/L; Syndel International,
Vancouver, BC, Canada). Light pressure was applied on
the abdomen of each fish and the milt was collected with
40 mL dry beakers. The initial male ejaculate was dis-
carded and the external urogenital pore was wiped dry
with a paper towel to avoid contamination. After strip-
ping, semen samples were held in a temperature con-
trolled (4–6 °C) cold room until processed.

Atlantic cod sperm smears were prepared in the
manner described by Butts et al [2]. In brief, sperm
smears were prepared by diluting 10 !L of semen in a
solution composed of seawater (500 !L) and 3% citrate
sodium (500 !L) [3]. It should be noted that in order to
obtain a large data set, comprised of thousands of
sperm cells in a relatively short time-span, a proper
sperm dilution ratio should be used. The ratio chosen
should be species specific or vary seasonally to coin-
cide with changes in sperm density. Ultimately, it is
best to choose a final dilution that prevents overlapping
of sperm cells so as to avoid inaccuracies in the assess-
ment of each cell’s dimensions. The sperm solution, as
just mentioned above, was gently shaken for 30 s. For
each male, 5 !L of this sperm solution was then pi-
petted onto a microscope slide (prewashed with 95%
ethyl alcohol) and prepared using Hemacolor [3]. The
smears were allowed to air dry, then permanently
sealed with Eukitt mounting medium (Kindler & Co.,
Freiburg, Germany) and topped with a coverslip. Dig-
ital images of sperm heads were captured using a Leica
microscope (model DMLB; Leica Microsystems Inc.,
Richmond Hill, ON, Canada) equipped with a micro-
publisher 3.3 RTV digital camera (Q-imagining, Sur-

rey, BC, Canada; Fig. 1 from the main text). Sperm
heads were measured at random for each smear with a
100# oil immersion objective. A digital image was
also captured of a stage micrometer, preferably
equipped with a linear rather than circular measure, to
be later used to calibrate the plug-in. It should be noted
that the scale of the micrometer should to be appropri-
ate for the magnification and microscope used. For
instance, if sperm images are captured using a specific
microscope, objective lens, and digital camera, the mi-
crometer image should also be captured using this same
system.

S1.2. Chinook salmon sperm collection and sample
preparation

To test the versatility of the ASMA plug-in we used
Chinook salmon as an experimental organism. In com-
parison to Atlantic cod, Chinook salmon sperm are not
so elliptical (cells are shaped more like a “gumdrop”).

Wild Chinook salmon were collected from the
Credit River in Mississauga, ON, Canada (43°35’N,
79°42’W) from 3 to 6 of October 2010 using electro-
fishing techniques. Upon capture, fish were humanely
sacrificed and semen samples were immediately placed
into clear bags and then stored on crushed ice until use.
During the entire sampling process special care was
taken to avoid contamination of semen with water,
blood, or urine. For each male, sperm smears were
prepared and stained using Diff-Quik according to
methods described by Tuset et al [4]. Digital images of
sperm heads were captured using an Olympus BX51
microscope equipped with an Olympus DP72 digital
camera.

S1.3. Installation and calibration of the ASMA
plug-in

ImageJ is an open source JAVA application (Na-
tional Institutes of Health, Bethesda, MD, USA) and is
available for download at http://rsbweb.nih.gov/ij/.
Several steps are required to properly calibrate and
synchronize the ASMA plug-in with corresponding
sperm head images. First, ImageJ (Mac OS X v. 1.42q
or higher) was opened and the digital image of the
micrometer was loaded (click File » Open » find the
previously saved micrometer image). In this case
the image had been captured using the system as de-
scribed above. Next, the straight-line selection tool,
located on the toolbar, was used to make a straight line
(on the loaded micrometer image) that corresponds to a
known distance (i.e., 100 !m; Fig. 2). The Set Scale
dialog was then opened (click Analyze » Set Scale), and
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the Known Distance and Unit of Length boxes were
properly adjusted (Fig. 2). ImageJ automatically filled
in the Distance in Pixels based on the length of the
straight line. The ASMA plug-in file entitled (Sperm_
morphology.txt; Appendix: A, online version only) was
then placed in the ImageJ plugins folder. On the first
line of the plug-in the distance and known statements
were then modified to correspond with values previ-
ously specified in the Set Scale dialog [run(“Set
Scale . . .”, “distance"1833 known"100 pixel"1
unit"!m global”); Fig. 2]. In addition, on the 15th line
of the plug-in [run(“Analyze Particles . . .”, “size"X-X
circularity"X-X bins"256], the size and circularity
detection thresholds were adjusted according to the
sperm morphology literature that is available for Atlan-
tic cod [2,5,6]. For instance, we chose a size threshold
between 2–7 !m and a circularity threshold between
0.70–1.0 [run(”Analyze Particles . . .“, ”size"2-7 cir-
cularity"0.70-1.0 bins"256].

S1.4. Measurement of sperm head morphology using
the ASMA plug-in

Digital images of sperm heads were opened (click
File » Open » find the previously saved image) and then
parameters were automatically measured using the
ASMA plug-in (click Plugins » Sperm morphology).
By checking the Area, Shape Descriptors, Perimeter,
and Fit Ellipse boxes in the Set Measurements dialog

(click Analyze » Set Measurements) ImageJ can auto-
matically generate nine sperm head morphology pa-
rameters [7]. In this study we focused solely on
sperm head length and width, as these are two of the
most commonly measured sperm head morphology
indices [8 –10]. Images of sperm and their boundaries
are displayed by the plug-in to enable the researcher
to perform a quality control check and eliminate
sperm detection errors if needed (Fig. 1 from the
main text). Cells that are not properly situated in the
image’s two-dimensional plane (i.e., standing verti-
cally) or are overlapping should be excluded from
any further analysis. The output file, containing all
the sperm head measurements, was then “cut and
pasted” into Excel, at which time sperm detection
errors were deleted.
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